Weblate.securedrop.club down for maintenance

Upgrading to the official image now that USE_TLS patch has been merged. Also move behind an nginx proxy for SSL. It will be back later today.

@nijel it looks like the docker image for weblate in the docker hub has not yet been re-generated to contain the EMAIL_USE_TLS variable override. Did I miss something ? It’s not really urgent or anything, just trying to get rid of my local modifications :wink:

weblate is back with https and a patch to the weblate docker deployment method was proposed to make this easier in the future

It was present in weblate:edge, but I’ve now pushed it to weblate:latest now (together with update to 2.15, which I somehow forgot to do on release).

1 Like

Are there any maintenance going on at the moment?

I logged on to the weblate instance now, and when trying to do translation it sometimes gives 502 errors from nginx:

There is no maintenance, I got that error once. Reloading should work. I think it may be because of the periodic index update. I’ll disable it and see how it goes.

@byeskille it turns out that the problem I fixed required a reboot which I did not do. I did the reboot now and testing that it works.

I did not get any 502 after two dozen tries. Please let me know if you get a 502 again and sorry for the inconvenience. And thanks for the report :slight_smile: